Back to overview
Downtime
Users experiencing Server Error
Aug 18 at 01:28pm EEST
Affected services
Website
Resolved
Aug 18 at 06:27pm EEST
Vendor implemented fix. Outage is resolved.
Affected services
Created
Aug 18 at 01:28pm EEST
Issue related to Vendor which is working to resolve the incident.
Affected services