Back to overview
Degraded
Website loading times are increased
Jun 29 at 04:58pm EEST
Affected services
Website
Resolved
Jun 29 at 08:02pm EEST
Everything is working.
Affected services
Website
Created
Jun 29 at 04:58pm EEST
The website performance currently seems to be sub-par. Our hosting provider acknowledged the issue already and they are actively investigating and working to solve the issue.
Affected services
Website